West Coast Seafarer 21' (intro)

hardydanger

Lieutenant
Joined
Aug 8, 2018
Posts
48
Likes
15
Age
48
Hey all.
Just a quick intro to my new 2013 Seaway Seafarer 21'
Currently named Penny Lane, but we might apply to Poseidon and a couple wind gods for a name change :)

Flag Blue
Outfitted with a 160hr Yamaha 115 with a 13.5x15K prop
Lenco tabs
Lewmar windlass
Brightwork for days
Bench Seat
No trailer (melted in one of the wildfires last year)
Comically oversized horn
Four rod holders

Issues:
- Both bilge pump currently inop
- Only seeing about 20knots at WOT about 5000rpm
- not sure what the issue is here, but will be doing a full service on the motor, cleaned the bottom today (which wasn't too bad)....might look for a spun prop....what else?

IMG_1800.jpeg

IMG_1836.jpeg

IMG_1878.jpeg

1618873406617.png

1618873468020.png

1618874436290.png
 

Toolate

Admiral
Joined
Aug 6, 2013
Posts
6,370
Likes
2,290
Location
Southwestern CT
First Name
Ben
Boat Make
1998 36' Sabre Express CAT 3116TA's, 2015 ROS Scotia 16 Etec 50
Not sure where to start but look around the web to see what prop you should have for the engine. Clean the growth off the boat and make sure fuel filters are clean. Might also see if you can confirm that your tach is really accurate- could be everything is ok but tach has you running slower.

I had the same hull but mine was 04. Had a 150 on it and ran close to 36Kts so would agree that you should see more speed than that. The boat was most comfortable under 20 and in a turn at higher speeds the prop would cavitation badly but I attributed that to the keel ventilating the outboard.
 

Shark49

Lieutenant Commander
Joined
Feb 10, 2018
Posts
136
Likes
34
Age
54
Try rising the engine. I had a 1700 skiff and had similar issue. Brought engine up so cavitation plate was even with Hull. It helped. Make sure you monitor the pisser for a stream.
 

Eastporter

Admiral
Joined
Sep 1, 2011
Posts
4,048
Likes
1,456
Location
MA
Boat Make
Sold- 20' Eastporter (Rebuilt 2011) 22' Pearson Ensign
Try rising the engine. I had a 1700 skiff and had similar issue. Brought engine up so cavitation plate was even with Hull. It helped. Make sure you monitor the pisser for a stream.
I agree- this engine looks too deep in the water. Screenshot 2021-04-25 6.07.46 PM.png
 
Top Bottom